Some problems with Nightfire

Support topics about the original PC game.
Forum rules
Note: This section may be used for the original Nightfire PC game (2002 release) related support. Do not post your Nightfire: Source related issues here. However we do our utmost helping you out, we do not offer official Nightfire PC support.
Post Reply

Topic author
Nadia Fortune
COMMUNITY NEWB
Posts: 3
Joined: 3 years ago

Some problems with Nightfire

Post by Nadia Fortune » 3 years ago

Problem 1: Framerate

I'm running this game on a computer that's WAY more advanced than what was around when this game came out (Nvidia GTX 660 and a six core AMD CPU running at 3.5 GHz, and a 1600x900 60 hertz monitor) but yet I still run into framerate lag when there are multiple character models on screen at one time. Especially odd given this game runs on the Half Life 1 engine, GoldSrc, and that game runs smooth as butter at all times. The framerate also takes a MAJOR nosedive if I change graphics settings in the menu, which is weird.

Problem 2: Animations not working right

Whenever I fire an automatic weapon, the animations don't play correctly. Instead of a constant "ratatatata" animation and sound, it only does a single "bam" animation and sound effect, but still acts like it's doing rapid fire (it's just too jarring to have the rapid fire function properly but not the animations for it). Also whenever I throw a grenade the animation of Bond's arm tossing it doesn't play, so it looks like there's a weird two second delay of the grenade being thrown straight out of Bond's chest.

I have the game patched to version 5.88 via automatic updates, so I dunno what the issue could be.

User avatar

click4dylan
_
_
Posts: 335
Joined: 5 years ago
Contact:

Re: Some problems with Nightfire

Post by click4dylan » 3 years ago

The grenade bug happens when cycling weapons to the grenade. I tried fixing it many times but couldn't figure out what exactly the problem is. If you switch to the grenade twice the problem goes away. You can fix the problem with the weapon firing animations by limiting your fps_max by typing fps_max 60 in the console. Not sure about your frame rate drops though. Changing video settings WILL lag the menu, its a bug that's existed since 1.0. It was fixed when we switched timer systems back in 2011 but over the past year or two we switched to a more accurate timer and the bug came back. We traded more accurate time for menu lag.


Topic author
Nadia Fortune
COMMUNITY NEWB
Posts: 3
Joined: 3 years ago

Re: Some problems with Nightfire

Post by Nadia Fortune » 3 years ago

Okay so some of what you said at least put my mind at ease, now that I know that menu bug is "normal" and yep you were right about the grenade bug. (for a quick way to know what I mean about framerate, the biggest offender is on the first mission at the party, the moment I enter the room with all the NPCs walking around my framerate just suddenly goes below 30)

However it seems the fps_max 60 console command didn't work. 60 FPS, and hell I even tried 30 FPS, and none of it worked to get weapon animations working properly. What I did notice a bit further is that this only effects weapon animations that involve holding down the "weapon fire" button, which of course is defaulted to mouse 1 (though I also tried it with the "enter" key as an alt and it was the same result). So it's not just automatic weapons, the pistol also doesn't animate past the first gunshot when holding down fire. One oddity though, limiting the FPS to 30 didn't fix the weapon fire animation, but it DID fix reload weapons when the clip is empty, meanwhile when the framerate is limited to 60 FPS the weapon reload animations only work when the clip is NOT empty, but an empty clip reload results in no animation. I should note I tried this both with vsync on and off, and with the refresh rate set to 60 hertz and "default." No matter what on those settings, fps_max 60 didn't work to fix the animations.

So yeah as I said, you are definitely right about the grenade and menu bugs, but the console command is, sadly, not working to fix my problem.

User avatar

click4dylan
_
_
Posts: 335
Joined: 5 years ago
Contact:

Re: Some problems with Nightfire

Post by click4dylan » 3 years ago

Believe it or not, it used to be worse. different FPS would cause different firing and movement speeds.

to try and fix your FPS problem in austria, the only thing I can think of to try is r_sleep 0. I haven't had any computer i've tested over the last 6-7 years have any issues with the fps itself


also i've just tested and found out that fps_max 60 does still have the animation bug, but these values DO fix it:

fps_max 32
fps_max 64
fps_max 102.4
fps_max 128


use one of these values and your fire bug will be gone


Topic author
Nadia Fortune
COMMUNITY NEWB
Posts: 3
Joined: 3 years ago

Re: Some problems with Nightfire

Post by Nadia Fortune » 3 years ago

fps_max 32 works, but none of the others worked for me. I admit I was kinda hoping to keep running this at 60 FPS (60 hertz is my monitor's refresh rate) but eh I've played console games for long enough in my life that 30 FPS really isn't as bad as some "PC elitists" make it out to be (so long as it's a stable 30 that is, and not constantly dipping like, say, Assassin's Creed Unity).

Still thanks for your help, and I'm glad you helped me find found one solution that works.

User avatar

click4dylan
_
_
Posts: 335
Joined: 5 years ago
Contact:

Re: Some problems with Nightfire

Post by click4dylan » 3 years ago

you should definitely go 144hz. i can never go back. 60hz looks like a slideshow to me now $D


Maxaxle
COMMUNITY ROOKIE
Posts: 12
Joined: 3 years ago

Re: Some problems with Nightfire

Post by Maxaxle » 3 years ago

Nadia Fortune wrote:Whenever I fire an automatic weapon, the animations don't play correctly. Instead of a constant "ratatatata" animation and sound, it only does a single "bam" animation and sound effect, but still acts like it's doing rapid fire (it's just too jarring to have the rapid fire function properly but not the animations for it).
I've had that for the past few years; IDK what to make of it.
click4dylan wrote:Believe it or not, it used to be worse. different FPS would cause different firing and movement speeds.

to try and fix your FPS problem in austria, the only thing I can think of to try is r_sleep 0. I haven't had any computer i've tested over the last 6-7 years have any issues with the fps itself


also i've just tested and found out that fps_max 60 does still have the animation bug, but these values DO fix it:

fps_max 32
fps_max 64
fps_max 102.4
fps_max 128


use one of these values and your fire bug will be gone
Ooh, I should try that.

User avatar

click4dylan
_
_
Posts: 335
Joined: 5 years ago
Contact:

Re: Some problems with Nightfire

Post by click4dylan » 3 years ago

I have released a new update to the original Nightfire to fix this problem

Moved from (PC) General to (PC) Support on 1 year ago by Rise2Shine

Post Reply