Problem, help? :-)

Support topics about the original PC game.
Forum rules
Note: This section may be used for the original Nightfire PC game (2002 release) related support. Do not post your Nightfire: Source related issues here. However we do our utmost helping you out, we do not offer official Nightfire PC support.
Post Reply

Topic author
snipe34
COMMUNITY NEWB
Posts: 4
Joined: 7 months ago

Problem, help? :-)

Post by snipe34 » 7 months ago

Hello everyone,

First of all, huge thanks to the people who are still keeping up this game. I couldn't believe my eyes that there was a community for this game. I played this game like some years ago and now i see there are still people playing it! Love it!


Then my problem... :-)

I installed the game and i installed the patch but if i want to play multiplayer to join server i can't get on because i don't have the map or if i want to creat my own game it crashes. Even if i want to play solo the game crashes.

For your information: I'm running windows 10

Can someone tell me what i did or do wrong?

Thank you in advance!

greetings,

Snipe


Topic author
snipe34
COMMUNITY NEWB
Posts: 4
Joined: 7 months ago

Re: Problem, help? :-)

Post by snipe34 » 7 months ago

Ow sorry, this had to be in the support area!

Moved from (PC) General to (PC) Support on 7 months ago by Rise2Shine

User avatar

Rise2Shine
_
_
Posts: 243
Joined: 5 years ago
Contact:

Re: Problem, help? :-)

Post by Rise2Shine » 7 months ago

Hi snipe34,

I quote the developers recent response to this issue:
click4dylan wrote:
10 months ago
There seems to be some weird issue going on with Windows 8/10 if DirectX is hooked while using compatibility mode on bond2.exe. I hooked directx to workaround a problem on nvidia graphics cards that has happened since the GTA 5 gameready drivers that causes graphical corruption, but when compatibility mode is enabled, which also seems to hook directx, it causes the game to crash whenever the device is attempted to be reset. This crash also happens when changing video settings. It's purely a windows bug and not a game/patch bug because it does not happen on Windows 7, and none of my hooks are doing anything incorrectly.

The solution is to either turn off compatibility mode on bond2.exe (I think the launcher might actually force it, though i can't remember), or click no on the latest patch when it asks you to enable the graphics corruption fix. I just released this new patch the other day.

None of this would be a problem if NVIDIA would just fix their drivers, but no matter how many times I have tried to reach out to them they have ignored me.
The important part is in red. Please make sure you updated the game to it's most recent version using the updater included in the download.

Rgds,
[eXs]Rise2Shine A.k.a. True
Nightfire: Source - Web | Community | Social | Former Level Designer

Live for the way that you cheer and scream for me.

Image


Topic author
snipe34
COMMUNITY NEWB
Posts: 4
Joined: 7 months ago

Re: Problem, help? :-)

Post by snipe34 » 7 months ago

Hello Rise2Shine,

I got it working!Played like 1 hour now and i already love it again but we need more players! :-)

Thanks mate!


Topic author
snipe34
COMMUNITY NEWB
Posts: 4
Joined: 7 months ago

Re: Problem, help? :-)

Post by snipe34 » 7 months ago

For the people who have the same problem...

I did the fallowing:

- bond2.exe -->compatible mod W7
- With the start of the game they ask for nvidea stuff just press no.

Post Reply