Page 2 of 2

Re: bond2.exe stops working when joining server

Posted: Tue Aug 08, 2017 11:07 am
by Agret
I can also confirm that the latest patch is a lemon, doesn't work on Windows 10.


I am not sure how to attach a file on this forum so can't post the dump file I generated.

Edit: Here is my dump while trying to connect to a server:!Ato-a1gkiH5U9V51MXJu4Bc0TqVd

Re: bond2.exe stops working when joining server

Posted: Tue Aug 08, 2017 10:54 pm
Ghost wrote:
1 year ago
downloaded both the game and the patch, updated them both, tried with version 5.91 :
You can only connect to servers with version 5.99, you get kicked for using older version.

Install / reinstall Microsoft Visual C++ redistributable 2005 (and higher, but you might miss the older version). Nightfire runs with 32bit VC++ so you need x86

You might want to exclude Nightfire from DEP. Altough I doubt this would work.
Agret wrote:
1 year ago
I can also confirm that the latest patch is a lemon
The patch is the reason Nightfire still exist and therefore this forum tab still exist. You could probably get Nightfire 1.0 somewhere and play with bots, because 1.0 is so glorious. :sarcastic:

edit: performed clean install on both windows 7 with AMD and windows 10 (version 15063) with Nvidia, both without problems

Re: bond2.exe stops working when joining server

Posted: Sun Aug 13, 2017 6:50 pm
by Neytiri
Since i play with the latest patch 5.99 , i cant play nf anymore as it always crashes with windows 10 when the 5.91 had no issues. Ignacio also saw the problem and many from the community has it still. He confirmed that it indeed wasnt supposed to work with windows 10 and if some of u can, its a kind of miracle. Anyways here is his post, but i dont understand any of it xD

" I looked at Orel's NF today and it simply seems to crash when trying to reset the 3D device at a function in renderd3d.dll that dispatches a call to apphelp.dll which later crashes down a specific function in that module. Either two things are going on here: one, the function that resets the device in renderd3d is passing an invalid pointer to apphelp.dll which is unlikely, two and possibly the culprit Win 8.1 apphelp.dll's function differs from Win 7/10's one causing the registers on the stack to be wrong thus causing an invalid pointer and crashing absolutely everything since it obviously doesn't have an exception handler of any sort, not to also mention that the new Bond.exe was specifically developed and tested on Windows 7, it miraculously works on Windows 10 (and I mean 'miraculously' because it wasn't intended / developed for it).

In short: Use an updated version of Windows (that is not 8 / 8.1) like Windows 10 with all the latest updates until 1703 or either use Windows 7.
Windows 7 and 10 are the officially supported O.S's.

Also, watch out for antiviruses and screen monitoring apps like Nvidia ShadowPlay / RTSS (Rivatuner) / MSI Afterburner, most of the time they try and inject / hook stuff in the application in order to perform rendering / capturing / monitoring on it, the hooks end up being wrong and the application crashes. Rivatuner, AVG and ShadowPlay used to crash many apps due to improper hooking / detouring of functions. Just my two cents anyway.
If all that I just said checks out, wipe the entire Nightfire folder and re-download it since it may be something that lies within NF itself."

Re: bond2.exe stops working when joining server

Posted: Mon Aug 14, 2017 5:00 pm
by Rise2Shine
Great research! Now it's important to report this to Dylan, as he's the one updating the old game :)
Knowing he's not very active around here as he took time off the games, you probably should message him on Skype, or ask @Ignacio to fix the issue.


Re: bond2.exe stops working when joining server

Posted: Wed Aug 16, 2017 12:01 am
by Neytiri
Ignacio couldnt fix it on Orel's computer even after all these researches :( maybe we should show all this to dylan.

Re: bond2.exe stops working when joining server

Posted: Tue Aug 22, 2017 6:49 am
by click4dylan
There seems to be some weird issue going on with Windows 8/10 if DirectX is hooked while using compatibility mode on bond2.exe. I hooked directx to workaround a problem on nvidia graphics cards that has happened since the GTA 5 gameready drivers that causes graphical corruption, but when compatibility mode is enabled, which also seems to hook directx, it causes the game to crash whenever the device is attempted to be reset. This crash also happens when changing video settings. It's purely a windows bug and not a game/patch bug because it does not happen on Windows 7, and none of my hooks are doing anything incorrectly.

The solution is to either turn off compatibility mode on bond2.exe (I think the launcher might actually force it, though i can't remember), or click no on the latest patch when it asks you to enable the graphics corruption fix. I just released this new patch the other day.

None of this would be a problem if NVIDIA would just fix their drivers, but no matter how many times I have tried to reach out to them they have ignored me.